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All other trademarks are the property of their respective owners. 
 
 
 

Introduction: 
 
The Insight Connector is a Microsoft Outlook™ MAPI plug-in that allows sharing with IMAP mail 
servers.  With the Insight Connector, an IMAP server can be used to provide the groupware 
functions of Outlook. 
 
As with any software, understanding and learning to use the product properly ensures excellent 
user experience and the right expectations.  
 
The objective of this document is to both train and educate users on what the Insight Connector 
will do and how it is intended to be used.  Some of the information will actually be Outlook-centric 
while other parts will be Connector-centric.  Since both are used in tandem, it is critical that both 
be discussed in this document. 
 
The documentation is organized into three sections.  First section discusses Connector 
Configuration; second section discusses Connector usage; third section discusses basic Outlook 
features.  
 
 

Technical Support 
 
When you purchase any of Bynari’s products, the products include one year of free support and 
maintenance.  To purchase additional yearly support and maintenance, please contact 
sales@bynari.net. 
 
With active Support and Maintenance, customers receive one year of product maintenance, 
upgrades and unlimited email and telephone support. 
 
Support is available to customers worldwide. 
 
To contact technical support:  
U.S. Toll Free Telephone:  1-800-241-1086 
International Telephone:  001-214-350-5772 
 
To open a new support ticket:  http://www.bynari.net/support/  
For FAQs:  http://www.bynari.net/users/kb.php 
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1 INSTALLATION 
 
 

1.1 Supported Platforms 
 
The Insight Connector has been thoroughly tested to work with Microsoft operating systems 2000 
and XP Pro.  Although customers have reported success on the Vista operating system, 
currently, it is not one of the supported platforms.  Use of the Insight Connector with Vista will be 
at the user’s discretion.  Bynari will assist when possible with any installation of the Insight 
Connector but may not be able to resolve strange behavioral issues that occur only in Vista. 
 
The Insight Connector has also been thoroughly tested with all of the recent versions of Microsoft 
Office.  Current supported versions are 2000 through 2007 of Microsoft Office. 

1.2 Preparing Your Workstation 
As with any software installation, preparing your workstation so that it can be cleanly installed is a 
must.  
 

1.3 A Clean Computer 
Make sure that you are working on a “clean” computer before installing the Insight Connector 
software.  A “clean” computer is a computer that is free from viruses, Trojans, Malware, Spyware, 
etc.  If your computer has any of these present, it will impact your software’s functionality.  It could 
cause simple instability of the product all the way to bizarre behavior that cannot be explained.  If 
your organization does not already employ strong antivirus software and anti-Spyware software, 
(this usually covers Trojans and Malware too) you can run an online scan of your pc to ensure 
that it is clean prior to installing any new software.  You must have administrative privileges to run 
these scans.  If you do not have administrative privileges, see your systems administrator for 
assistance. 
 
(Computer Associates) 
Antivirus Scanner:  http://ca.com/us/securityadvisor/virusinfo/scan.aspx 
Anti-Spyware Scanner: http://ca.com/us/securityadvisor/pestscan/ 
 
NOTE: These online scanners do not have the ability to clean your computer but they can tell you 
if it is infected. 
 

1.4 A Note about antivirus software 
Antivirus software is an absolute necessity today.  However, antivirus software has the potential 
to affect the performance of your other applications.  Most of the reputable commercial software 
companies on the market today are fully compatible with the Insight Connector.  The Insight 
Connector works well with Norton, McAfee and Computer Associates, to name a few.  The only 
specific software brand that has been reported as “not compatible” with the Insight Connector 
was AVG, the free antivirus software version. 

1.5 A Note about Add-ins (or Plug-ins) 
There are quite a few Add-ins available for Windows and Outlook today.  Many of these 
enhancements function with little detriment to the rest of the computing environment.  Others, 
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however, can cause some serious issues, specifically with email.  Some of the tools that have 
caused issues are: 

• Google Desktop  
• Microsoft Desktop Search 

 

1.6 Microsoft Update 
Make sure that you have all of the necessary updates to both Windows and Microsoft Office prior 
to installing the Insight Connector.  Outlook bugs are fixed and deployed to the Microsoft Update 
repository on a regular basis.  Ensuring that you have an up-to-date operating system and Office 
application will make installing the Insight Connector easier and stable.  Microsoft Update is the 
new version of what used to be Windows Update.  It now encompasses both Windows and Office 
for a more complete solution to desktop software bug patch updates. 

1.7 Potential Issues with Vista 
There are a few potential issues with Vista when installing the Insight Connector.   
 
An administrator might encounter the “User Account Control” (UAC) feature of Windows Vista.  
UAC is a new administrative control appearing for the first time in the Vista operating system.  It 
allows an IT administrator to give temporary authority to a user for a specific need.  It is very 
similar to the “sudo” command in Linux.  For an in-depth explanation of UAC read the following 
article: 
http://www.bynari.net/support/users/kb.php?id=200095&category_id=0&sid2=b337ff8c56260fbd7
95ae746dbfddd34 
If you experience an issue with Outlook going offline in Vista, it may be because Vista disables 
the telnet client by default.  This feature is needed by the Insight Connector and needs to be 
enabled.  To correct this issue, go to: 
Control Panel > Programs > Turn Windows Features on/off  
Turn on the telnet client.   
 

2 INSTALLING THE INSIGHT CONNECTOR 
 

2.1 Download Software 
The latest version of the Insight Connector is located here: 
http://www.bynari.net/public/products/InsightConnector/latest 
If you do not have your license keys, you can contact Bynari technical support by opening a 
support ticket: http://www.bynari.net/support or by phone (216)350-5770 X26. 
 
A complete installation guide for the Insight Connector can be obtained here: 
http://www.bynari.net/downloads/connector/documentation/latest/3  
For more detailed steps on installing the Insight Connector, please reference the administrator’s 
guide. 
 

2.2 Single-Click Installation 
The Insight Connector Single-Click Installation is a tool designed to help administrators install 
multiple Insight Connectors on several desktops without being required to configure each 
separately.  The Single-Click Installation is a time-saver for anyone configuring and implementing 
the Insight Connector in a business environment. 
 
The Single-Click Installation is composed of the following items: 

1. Insight Connector executable 
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a. This is the actual program that will be installed on the computer. 
2. Setup.ini file 

a. This is a text file that will contain the configuration parameters that will be used to 
configure the Insight Connector. 

 
Items you will need: 
You will need to download the latest version of the Insight Connector and the sample.ini file.  The 
Insight Connector can be obtained here: 
Standard Connector 
http://www.bynari.net/public/products/InsightConnector/latest/noini 
iCal Connector 
http://www.bynari.net/public/products/InsightConnector/latest/noini-ical 
iCal-Kolab Connector 
http://www.bynari.net/public/products/InsightConnector/latest/noini-ical-kolab 
 
The sample.ini file can be obtained here: 
http://www.bynari.net/support-files/example-connector_setup.ini 
 
To install the Insight Connector with minimal user intervention, the administrator can modify a 
“setup.ini” file that will answer questions about configuration settings. 
 
NOTE: The editable parameters in this sample “.ini” file are there for representation only.  You will 
need to customize these parameters to match your specific installation and environment. 
 

2.2.1 Installation Steps 
1. Unzip and place the install package and the setup.ini files into a new folder under your root 

directory (usually this is the C:\ directory). 
2. Open the example-connector_setup.ini file with a text editor (i.e. notepad or vi) and modify 

the parameters to meet your installation specifications. 
 

NOTE:  Details for modifying this file are listed at the end of this section. 
 
3. On the Windows desktop, select Start > Run > Browse 
4. Navigate to the “new folder” you placed the setup.ini file and the unzipped installer file for the 

Insight Connector. 
5. Select the install package and then click “Open”. 
6. This will place the Insight Connector installation file in the dialog window.   
7. At the end of the dialog window, after the “.exe” of the installation file, enter the following: 

/y C:\folder name\setup.ini /silent 
 

NOTE: the “folder name” should be the name you gave the folder when you created it in step 1 
and the “setup.ini” should be the name of the “.ini” file.  The dialog window should look similar to 
this:  C:\tmp\Bynari-InsightConnector-3.1.5-1212232.exe /y C:\setup.ini /silent 
 
8. Select “OK” to start the installation. 
9. When the installation is complete, you can open Outlook with the Connector already 

configured and ready for use. 
 

2.2.2 Description of changes for setup.ini 
NOTE: Semicolons “;” are used to comment out elements in the setup.ini file. 
 
[Misc] 
Verbose=No 
Logfile= 
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Determines logging during installation.  Enter the full path for the log file i.e. 
Logfile=C:\tmp\connector_log_file.txt 
 
[Profile] 
NewProfile=Yes 
This parameter creates a new profile to use with the Insight Connector during the installation 
process. 
 
DefaultProfile=Yes 
This parameter sets the newly created profile as the default in Outlook.  When the user opens 
Outlook, it will default to this profile automatically. 
 
ProfileName=Bynari Insight Connector 3.0 
The profile name is a user-defined field and can be changed to fit the company's naming 
conventions. 
 
ProfilePassword=  
Profile Password is an Outlook option. It requires a user to enter a password when starting 
Outlook under that specific profile.  No password is needed for configuration.  Leaving this entry 
blank disables the Profile Password feature in Outlook. 
 
Options=Default 
“Options” configures Outlook to either “prompt” for a user profile to use, “default” to a specific 
profile or leave Outlook unchanged.  
Prompt - will prompt the user to select a profile to use. 
Default – sets the profile specified in “ProfileName” as the default. 
None – leaves Outlook settings for profiles unaltered. 
 
[Export] 
Options=Show 
Configures the display of the export wizard pages during set up.   
Options are: 
Show – Display the export wizard. 
Hide – Do not display the export wizard. 
 
;ProfileName=Outlook profile name to be used 
This parameter allows for specific selection of a profile name during installation for the exporting 
of mail data.  This feature is disabled by default. 
 
;ExportPSTFile=C:\Documents and Settings\jdoe\Local Settings\Application 
Data\Microsoft\Outlook\Outlook.pst 
This parameter will override the “ProfileName” parameter.  It allows for a specific path to a PST 
file for the mail export process.  This feature is disabled by default. 
 
NOTE: ProfileName exports a profile while ExportPSTFile exports a PST file.  Only one option 
may be used at a time.  If both are commented out “;” then neither option will be used. 
 
Folders=All 
This option tells the export wizard which folders to export from during the export process. 
Options are: 
Inbox – exports the Inbox only. 
All – exports all folders 
 
LoginAsManager=No 
This option enables a “manager” log in to export the profile or PST file. 
Default is “No”. 
 
AddOutlookFormat=Yes 
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This option allows for the creation of Microsoft Format (TNEF – winmail.dat) attachments during 
the export process.  Default is “Yes”. 
 
AddiCal=Yes 
This option allows for the creation of iCal attachments during the export process. 
Default is “Yes”. 
 
AddKolab=Yes 
This option allow for the creation of Kolab attachments during the export process. 
Default is “Yes”. 
 
[Common] 
InstallPath=C:\Program Files\Bynari, Inc\InsightConnector 
This is the default location; it can be installed on any available drive. 
 
[Connector] 
ConnectorKey=12345678901234567890123456789012  
 
NOTE: This is not a valid key; you must obtain a valid key from sales@bynari.net 
 
Even if auto registration is turned on the setup.ini requires this for completion. This will not be 
checked after the first time the Insight Connector is used. 
 
DisplayUI=No 
Display the user configuration dialog window.  
Default is “No”. 
 
EnableAutoRegistration=No 
When enabled, this option verifies the Insight Connector license with the user’s Insight Server 
automatically each time Outlook is started.  This feature is only available for users of the Insight 
Server.  Default is “No”. 
 
AutoRegistrationPort=80 
The port that auto-registration uses to contact the Insight Server for proper license validation.  
Port 80 is the default http port for non-encrypted traffic. 
 
AutoRegistrationSSL=No 
When enabled, this feature allows for auto-registration to be sent across an SSL encrypted port.  
The SSL port number must be specified in the “AutoRegistrationPort” parameter.  The standard 
SSL port is 443.  Default is “No”. 
 
UpdateConfig=No 
Update any existing Insight Connector configuration with the parameters in this setup.ini file.  
Default is “No”. 
 
HideToolbar=No 
Choose whether to display the Insight Connector Toolbar or hide the toolbar.  Selecting “No” will 
actually display the toolbar and “Yes” will hide it.  Default is “No”. 
 
CustomCache=0 
This option allows for custom local cache to be used.  Default is “0”. 
0=No  
1=Yes 
 
localCacheDir= 
Specify the path to the custom local cache location.  The “CustomCache” parameter must be set 
to “1” to use this option. 
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auto_send_recv=0 
This option configures Outlook for automatic Send/Receive of email.  Default is “0”. 
0=No 
1=Yes 
 
auto_send_recv_timeout=0 
This parameter configures the number of minutes between a Send/Receive function in Outlook.  
The “auto_send_recv” parameter must be set to “1” to utilize this feature. 
 
receiptResponse=1 
This parameter tells Outlook how to respond to read receipt requests on incoming messages.  
Default is “1”. 
0=Always send a response 
1=Never send a response 
2=Prompt me before sending a response 
 
ProgressDialogThreshhold=50 
This numeric value represents the minimum number of messages needed for the progress 
indicator to display when synchronizing new mail.  Default value is 50.    
 
ShowProgressDialog=1 
This parameter configures whether or not the Insight Connector progress dialog indicator will 
display.  Default is “1”. 
0=No 
1=Yes 
 
DefaultStore=Yes 
This parameter is used to configure the Insight Connector to be the default mail store.  Default is 
“Yes”. 
 
AccountDisplayName=Insight Server Folders 
This value configures the display name for the IMAP server folders in Outlook. 
 
ShowAllFolders=1 
This parameter tells the Insight Connector whether to display all folders in the IMAP store or not.  
Default is “1”. 
0=No 
1=Yes 
 
SendReceiveAllFolders=0 
This parameter configures the Insight Connector to perform a Send/Receive on all IMAP folders 
every time Outlook performs the Send/Receive function.  Default is “0”. 
0=No 
1=Yes 
 
DownloadHeadersOnly=1 
This parameter configures the Insight Connector to download email headers only when retrieving 
email.  Default is “1”. 
0=No 
1=Yes 
 
YourName=John Doe 
User’s name 
 
Organization=Example Company 
Name of your company (optional) 
 
EmailAddress=jdoe@example.com 
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The user's email address 
 
IMAPUserName=jdoe 
User name  
 
IMAPPassword=password 
User's password  
 
NOTE: This is a text file only; any password you insert will be viewable to anyone that obtains this 
.ini file.   
 
RememberPassword=1 
Configures the Insight Connector to remember the IMAP Password entered in the 
“IMAPPassword” parameter.  Default is “1” 
0=No 
1=Yes 
 
UserPersistentConnection=1 
This parameter configures the Insight Connector to use persistent connections. Using persistent 
connections will prevent the need for repetitive connecting and disconnecting of Outlook each 
time a Send/Receive function is performed.  Default is “1”. 
0=No 
1=Yes 
 
InconingPort=143 
This value configures the Insight Connector IMAP port.  Default is 143. 
 
IncomingServer=mail.example.net 
This value configures the Insight Connector IMAP server address.  Mail.example.net is for 
example purposes only. 
 
UseIncomingSSL=0 
This parameter configures the Insight Connector to use IMAP SSL.  When using IMAP SSL the 
default value for “IncomingPort” is 993.  Default is “0”. 
0=No 
1=Yes 
 
SMTPUserName=jdoe 
This value specifies a valid “userid” for sending email. 
 
SMTPPassword=password 
This value is the password that accompanies the SMTPUserName.   
 
RememberSmtpPassword=1 
Available options: 
1 = Remember SMTP Password 
0 = Do not remember SMTP Password 
 
UseIMAPAuthForSMTP=1 
This parameter configures the Insight Connector to use the IMAP authentication credentials for 
SMTP authentication also.  Default is “1”. 
0=No 
1=Yes 
 
OutgoingPort=25 
This value configures the SMTP port.  Port 25 is the default SMTP port. 
 
OutgoingServer=mail.example.net 
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This value configures the SMTP server address. 
 
UseOutgoingSSL=0 
This parameter configures the Insight Connector to use SMTP over SSL.  The value in 
“OutgoingPort” should be configured accordingly if “UseOutgoingSSL” is used.  Default is “0”. 
0=No 
1=Yes 
 
RequiredSMTPAuth=1 
This value configures the Insight Connector to require SMTP authentication.  Default is “1”. 
0=No 
1=Yes 
 
UseSMTP_Auth=0 
This value configures the Insight Connector to use SMTP authentication.  Default is “0”. 
0=No 
1=Yes 
 
NOTE:  UseSMTP_Auth and UseIMAPAuthForSMTP are not the same thing and only one can be 
used at a time.  UseIMAPAuthForSMTP uses IMAP credentials for SMTP whereas 
UseSMTP_Auth uses the values of SMTPUserName and SMTPPassword for authentication. 
 
UseSMTP_TLS=0 
This parameter configures the Insight Connector to use Transaction Layer Security (TLS).  
Default is “0”. 
0=No 
1=Yes 
 
ServerTimeout=0 
This parameter configures the server disconnect timeout value.  The value represents the time, in 
seconds, that the client requests the server to wait before timing out and disconnecting.  Values 
can be 0, 30-600.  Default is “0”. 
 
[FreeBusy] 
 
;PublishRange=2 
This value represents the number of months of free/busy information to keep on the free/busy 
server.  Default is “2”. 
 
;UpdateFreeBusy=10 
This value represents the number of minutes between free/busy updates from the client to the 
free/busy server. 
 
;ReadURL=http://mail.example.net/freebusy/%NAME%.vcf 
The ReadURL is the equivalent to the “Search Location” under free/busy configuration in Outlook.  
It is the place that Outlook “reads” a person’s “free/busy” information from.   
 
;WriteURL=ftp://mail.example.net/freebusy/%NAME%.vcf 
The WriteURL is the equivalent to the “Publish at my location” value under free/busy configuration 
in Outlook.  This location is where the client will update the server with their free/busy information. 
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2.3 Configuring the Insight Connector 
Upon installing the Insight Connector and opening Outlook, you will see the Insight Connector 
Settings dialog window.   

 
Figure 1 – Insight Connector Settings dialog window 
 
Enter your User Information, Server Information and Logon Information in the spaces provided.  
When you have completed this, be sure to place a check in the box titled, “Remember Password” 
and click “Test Account Settings”.  When the Insight Connector has successfully made contact 
with the server, you will see a “successfully connected to the IMAP server” dialog window. 

2.3.1 Additional Settings: 
To learn more about the additional settings which are available for configuration, click the “More 
Settings…” button. 
 
Across the top of this new window, you will see seven tabs: General, Connections, Folders, 
Send/Receive, Miscellaneous, Format, and About. 
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Figure 2 – Insight Connector More Settings, General 

2.3.2 General 
The General tab has two input fields.  The first one is already filled in with a default value – 
“Insight Server Folders”.  This is the name that will appear as the display name for your “Outlook 
Today”.  It can be changed to a name of your choosing.   
 
The second field labeled, “Other User Information”, is optional and has no effect on the 
functionality of the software.
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2.3.3 Connections 
On the Connections tab, you can configure the port settings, SSL, etc.  Default values are 
automatically inserted during installation. 

 
Figure 3 – Insight Connector More Settings, Connections 
 
Incoming Server (IMAP): 

• By default, Insight Server uses port 143 and requires a “Use Persistent Connection” 
value.  Persistent Connections are recommended unless prohibited by your network 
administrator.  Without Persistent Connections enabled, Outlook will constantly perform a 
“connect/disconnect” operation with the mail server.   
 

Note: disabling the use of persistent connections will negatively affect the performance of the 
Insight Connector to your server because it will cause excessive network traffic.  
 
• Use secured connection (SSL) is another option you can use if your server supports SSL.  

By default, the port value will change to port 993 when SSL is checked.  This value can 
be changed if necessary. 

 
Outgoing Server (SMTP): 

• Use secured connection (SSL) utilizes the SMTPS protocol.   
• Use Transaction Layer Security (TLS) has the features of SSL encryption of both 

authentication and data sequences while still running over SMTP.  TLS is the preferred 
method for SSL encryption. 

• Port – the default SMTP (non-secure) is 25 
 
SMTP Authentication: 

• SMTP server requires Authentication:   
 

NOTE: SMTP Authentication is sent in plain text.  To encrypt the user ID and password – 
enable Use Transaction Layer Security (TLS). 
 
• Use Same Authentication as Incoming Server:  This uses your email log in and password 

entered when you setup the account. 
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Use SMTP Authentication: This option is usually used when sending email from an SMTP 
server that is not part of the normal mail server network, i.e. an external address or a 
remote user.  Enabling this feature tells the client to authenticate with the server to relay 
messages to external domains. 
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Timeout Setting: 

• The Timeout Setting tells the server how long to wait before it closes out the session.  
The default value is “0” and acceptable values are: “0”, “30-600” seconds.  In a corporate 
environment where the user is on the same network as the mail server, a timeout value of 
“0” is normally adequate.  

• Users on a Wide Area Network (WAN) need to consider larger timeout settings.  Setting 
this value is dependent on your Internet connection speeds.  If you are on a dial-up 
connection, you would want to set this value to 600 seconds whereas if you are on a DSL 
connection or cable modem connection, 60 seconds may be acceptable.  

• Having a value too low can cause uploading issues when sending large attachments 
where the Internet upload speeds are usually slow. 

 
Auto Registration Port: 

• Auto Registration is enabled by default and allows Insight Connector clients to verify 
licensing with their local Insight Server.   

• If you do not use the Insight Server, you will need to uncheck the Auto Registration Port 
checkbox.  (see below) 

• By default port 80 is used.   
 

2.3.4 For more information, go to section 3.1.4 “Registering the Insight 
Connector”. 

2.3.5 Folders 
Under the Folders tab, you can configure the default behavior of IMAP folders used by the Insight 
Connector. 

 
Figure 4 –Insight Connector More Settings, Folders 
 
Folder Type: 

• “Use ACLs to set folder types”. This option is enabled by default.  Default folders that 
Outlook must have are: Appointment, Contact, Task, Journal, Notes, and Mail. 

 
Folder List: 
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• Show All Folders.  This is enabled by default and tells the Insight Connector to 
automatically subscribe to all folders found under the User’s folder list. 

• Show Only Subscribed Folders. In large environments, the default value of “Show All 
Folders” may not be desirable.  This option allows the user to individually select only the 
folders they want to see in Outlook. 
 

NOTE: When manually selecting folders, be careful not to unsubscribe to “necessary” folders, i.e. 
Calendar, Contacts, Deleted Items, Sent Items, Outbox and Tasks.  Doing so will cause Outlook 
to recreate them on the IMAP server.  This is a default behavior of Outlook. 
 

2.3.6 Send/Receive 
The Send/Receive tab allows users to control the Insight Connector’s default behavior when 
sending and receiving messages to the IMAP folders. 

 
Figure 5 – Insight Connector More Settings, Send/Receive 
 
Download Headers Only: 

• Enabled by default, this option improves performance of the initial synchronization of the 
emails downloaded for Outlook.  When the message is selected for viewing, the entire 
message is downloaded. 

 
Show progress indicator when loading messages: 

• When this box is checked, a progress indicator will appear when synchronizing any folder 
with more than 50 messages in it.  By default, this option is checked. 

 
Indicator threshold (number of messages): 

• This option allows you to modify when the indicator will appear.  By default, this value is 
set at 50 messages, but it can be set all the way down to a single message. 

 
Send/Receive checks mail in all folders: 

• This option is off by default.  By enabling this option, the Connector will check for new 
messages in ALL folders when either the Send/Receive button is selected or when the 
automatic Send/Receive function of Outlook activates. 
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NOTE:  The automatic Send/Receive feature of Outlook is not enabled by default.  To enable 
it, follow these steps: 
 

o On the Outlook Toolbar, select Tools > Options 

 
Figure 6 – Outlook Tools, Options 
 

o This opens a new window, select the Mail Setup tab 
o Make sure the “Send immediately when connected” checkbox is checked 

 
Figure 7 – Outlook Tools, Options 
 

o Click the Send/Receive button 
o Check the box under “Setting for group “All Accounts” labeled “Schedule an 

automatic send/receive every”.  The default value is 5 minutes.  This number can 
be adjusted as desired. 
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Figure 8 – Outlook Tools, Options, Send/Receive 
 

o Click Close > OK to exit 
 
Send/Receive checks mail in these folders: 

• This option enables you to select which folders are checked during the Send/Receive 
operation. 

 

2.3.7 Miscellaneous 
The Miscellaneous tab contains two sections, one for read receipt request options and the 
second for local cache options. 
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Figure 9 – Insight Connector More Settings, Miscellaneous 
 
Message Receipt Options 
 
Prompt me before sending a response: 

• This option is the default setting.  It gives you the choice of sending a read receipt 
response or not when a request is made. 

 
Always send a response: 

• This option automatically sends a response to the sender of a read receipt request. 
 
Never send a response: 

• This option never sends a response to a read request receipt. 
 
Local Cache Options 
The local cache is a local copy of your email and attachments.     
 
Default Location: 

• The default location for the local cache is: 
o C:\Documents and Settings\[user name]\application data\Bynari\Bynari Insight 

Connector 3.0\Accounts\[Outlook profile name]\[email address]\.   
o The name of the local cache file is: Localcache.db 

 
Custom Location: 

• This option allows you to change the location of the local cache.  This enables the 
administrator to place the local cache on the network through a network share for user 
data backup if needed.   
 

NOTE: The user will need Read, Write, Delete and Change permissions in the Custom 
Location you choose. 
 
NOTE: Any changes made to the location of the local cache require a restart of Outlook.  If 
you do not restart Outlook, you may see errors because the Insight Connector must create 
the Localcache.db file – this is completed at startup if it does not already exist. 
 

2.3.8 Format 
Under the Format tab, you will notice a single option, “Use Microsoft Message Format”.  This 
default option creates a winmail.dat attachment which stores groupware items back on the server.  
If you use a Kolab server or an iCal compatible server, you may not need winmail.dat.  If you are 
unsure about this option, it is best to leave it enabled. 

2.3.9 About 
The about tab provides information about the Insight Connector.  It contains the version number 
as well as all licensing information. 
 

3 BASIC OPERATION 
 

3.1 Insight Connector 
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3.1.1 Insight Toolbar 
There are four buttons on the Insight Connector Toolbar:  Folder, Refresh Folders, Account, and 
About.  If you do not see this Toolbar and you are sure you have the Insight Connector correctly 
installed, verify that it is not disabled.  To check this, do the following: 

• On the Outlook Toolbar click Help > About Microsoft Office Outlook 
• In the lower right corner of the new window that opens, select the button labeled 

“Disabled Items”. 
• Select Bynari Insight Connector 3.0 and then select the “Enable” button. 
• Close > OK 

 
Folder: 

 
Figure 10 – Insight Connector Toolbar, Folder 
 

• With the Folder (Permissions) button, you can share folders to other users on the same 
server.   

• By default, you will see two names in the permissions window (minimum).  The first name 
is your username and the second is the manager account. 

• Under this window, you will see a pull-down menu which has “Administrator” displayed.  
This means that your account and the manager account both have administrative rights 
to your folders.  If or when you share with other users, caution needs to be taken when 
assigning the permissions to those users. 

• To share with another user on your server, follow these steps: 

 
Figure 11 – Insight Connector, Inbox Folder Permissions 
 

o Open the Navigation Pane if it is not already visible.  Alt + F1 will toggle the 
Navigation Pane on/off. 

o Select the folder you wish to share with other users.  For example, if you have a 
folder named “Sales” that you wish to share, click on the folder.  

o Select the “Folder” button on the Insight Connector Toolbar 
o Select “Add” and type in the full email address of the user you want to share the 

folder with – for example user2@example.net 
o Click OK 
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o Choose what permission level you wish to give the user you just added.  Options 
are: 

� Guest (Look up, Read, Set Seen Flag rights) 
� User (All rights except for ‘Create’, ‘Delete’, and ‘Administrator’) 
� Power User (All rights except for ‘Administrator’) 
� Administrator (Full rights) 

o By selecting the “Advanced” button, you can select the actual permissions that 
the user has to your shared folder. 

o These permissions are as follows: 
� Lookup 
� Read 
� Set Seen Flag 
� Write 
� Insert 
� Post Create 
� Delete 
� Administrator 

• To remove a user’s permission from a shared folder, follow these steps: 
o Select the folder you wish to remove a user’s permissions from within the folder 

tree. 
o Select the “Folder” button on the Insight Connector Toolbar. 
o Highlight the user’s name that you want to remove and then select the “Remove” 

button. 
o Click “OK” 

 
 
Refresh Folders 

 
Figure 11 – Insight Connector Toolbar, Refresh Folders 
 

• The “Refresh Folders” button refreshes the folder tree as seen when you press Alt + F1 
(navigation pane).  When pressed, the Insight Connector actually scans each folder, not 
for contents but for the folders themselves.  If folder changes are made on the server or if 
folders are shared to you from someone else, you would use the “Refresh Folders”.   
 

NOTE: The “Refresh Folders” button does not retrieve emails; it refreshes the folder tree only. 
 
Account 

 
Figure 12 – Insight Connector Toolbar, Account 
 

• Selecting the “Account” button will display a dialog containing your email account 
information.  This dialog is the same as discussed in the section on how to setup the 
Insight Connector.  For more information on the “Account” settings, refer to the section 
titled, “Configuring the Insight Connector”. 

 
About 

 
Figure 13 – Insight Connector Toolbar, About 
 

• The “About” button displays the license information as well as the version of the Insight 
Connector you are using.  This information is helpful when contacting Technical Support 
for assistance. 
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3.1.2 Namespace 
• If you have configured the Insight Connector for use with a server other than the Insight 

Server, you may notice that the Calendar and Contacts folders appear as subfolders to 
the Inbox.  With the Insight Server, altnamespace is used to alter the namespace so that 
the subfolders of “Inbox” actually appear as “top level” folders with any IMAP client. 

• If your server does not use altnamespace, you will see this “subfolder” type behavior 
within Outlook.  For example, on a Courier IMAP server, it uses “INBOX” as the folder 
namespace root.  All private folders on a Courier server will be labeled 
“INBOX.foldername” and all public folders will be labeled “#shared.foldername”. 

• This is not a flaw or configuration error on the Insight Connector; rather, it is namespace 
functioning correctly on your server. 

3.1.3 Auto-download of emails with Other Folders 
• The Insight Connector does not control how often email is checked; this is a function of 

Outlook as referenced under the category “Send/Receive” in this document.  The Insight 
Connector can tell Outlook which folders to check when it does a Send/Receive.  If you 
would like to have a folder other than the “Inbox” checked during the normal Outlook 
process of Send/Receive, follow these steps: 

o On the Insight Connector Toolbar select “Account” 
o Select “More Settings” 
o Select the “Send/Receive” tab 
o Insure that “Send/Receive checks mail in these folders” is selected 
o Place a check beside the folders you want emails downloaded during the normal 

Outlook Send/Receive process 
o Click “OK” and “OK” 

 
NOTE: Great consideration should be given before selecting other folders for auto-download 
synchronization.   Selecting large shared folders to be checked regularly by Outlook could cause 
excessive load on the server and produce a “sluggish” Outlook experience for the user. 
 

3.1.4 Registering the Insight Connector 
• The Insight Connector has an “auto-registration” feature built into it.  When used in 

conjunction with the Insight Server, it will automatically look to see if a valid Insight 
Connector license exists for the user.  With successful validation of the Insight 
Connector, there is nothing further for the user to do to register the software. 

• If you are using the Insight Connector with a different IMAP server, you will need to first 
disable the auto-registration function and then register it with your license key code: 

o On the Insight Connector Toolbar select “Account” 
o Select “More Settings” 
o Select “Connections” 
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o Uncheck “Auto Registration Port” 

 
Figure 14 – Insight Connector Account, Connections – Auto Registration 

 
o Select the “About” tab 
o Select the “Register” button 
o Enter the license key code for the Insight Connector 

 
Figure 15 – Insight Connector Account, Connections – Manual Registration 
 

o Select “OK” 
 
Changing your computer’s name will affect the Insight Connector’s registration.  To fix this issue, 
you will need to make a minor registry edit.  Here is the complete, step-by-step article: 
http://www.bynari.net/support/users/kb.php?id=200081&category_id=0&sid2=b337ff8c56260fbd7
95ae746dbfddd34  



Insight Connector Usability Documentation 

Revision date: 01/21/10 
 

25 

4 ADVANCED USE 

4.1 Insight Connector 
 

4.1.1 Server timeout settings on the WAN 
• The server timeout settings function was discussed in detail in the “Configuring the 

Insight Connector” section.   
• A value greater than “0” is recommended for all WAN (Wide Area Network) users of the 

Insight Connector. 
• Acceptable values for the timeout settings are “0”, “30-600” seconds. 
• Steps to change the timeout settings: 

o On the Insight Connector Toolbar, select “Account” 
o Select “More Settings” 
o Select “Connections” 
o Under the section titled “Timeout Setting”– enter the value in the input box. 

 
Figure 16 – Insight Connector Account, Connections, Timeout Setting 
 

o Click “OK” and “OK” 
o No need to restart Outlook with this change. 

 

4.1.2 Multiple Sub-folders with the Insight Connector 
• Within each of the user’s folders on the IMAP server, there is a hidden synchronization 

file.  This file tells Outlook what the folder type is:  i.e. Calendar, Contacts, and Tasks. 
• Anytime you select the “Refresh Folders” button or open Outlook, the Insight Connector 

searches through each folder for this hidden file.   
• The more folders you have, the longer it will take for the Insight Connector to scan 

through all of the folders.   
• Sometimes users with excessive sub-folders will notice that it takes Outlook longer to 

startup than before.  This is because the Insight Connector must search all of the folders 
for the hidden synchronization file. 
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4.1.3 Sharing Folders 
• The specific details of permissions are outlined under the BASIC OPERATION, Folders 

section of this document. 
• Sharing one folder is the same whether it is a mail folder, Calendar or Contact item.  

Steps to share a folder are: 
o To share your calendar with another user, start by viewing the Folder List.   
o On the Outlook Toolbar go to Go > Folder list 
o Once in the folder list, click on the Calendar icon – your calendar will appear 
o On the Insight Connector Toolbar, select “Folder” 
o To add a user to your calendar, select “Add” and then type in the user’s email 

address in the new window provided.   
o Click “OK”. 

 
NOTE: You can only share folders to other users on the same mail server. 
 

o Highlight the user you just added and using the pull-down menu below, assign 
the authority level for that user.  You can select any of the following: 

� Guest 
� User 
� Power User 
� Administrator 

o Using the “Advanced” button, you can select which permissions the user is 
allowed with the folder contents if the default permissions are not acceptable. 

o For more information on the permissions, go to the section titled, “BASIC 
OPERATION”, “Folder”. 

o Once you have saved these additions by selecting “OK”, the user can open the 
shared calendar. 

o On the user’s workstation, open the Folder List. 
o On the Outlook Toolbar, go to Go > Folder list 
o If you are using Insight Server, you will see a folder called, “Other Users” – 

expand this folder. 
o Within the “Other Users” folder, you will see the names of users that have 

permissions to the folder 
o Expand the desired user and you will see a Calendar icon. 
o Click on the Calendar – you will see the calendar displayed within Outlook. 
o Select Go > Calendar from the Outlook Toolbar 
o You will now see a second calendar option under the “My Calendars” section.   
o You can choose to either display one or the other or both calendars. 

NOTE: Shared Calendars are often large in size, and it could take several minutes to 
do the initial synchronization of all of the events.  Be patient, and let it finish before 
clicking other folders within Outlook. 

 
 

4.1.4 Free/Busy Information 
• Free/Busy Information is configured by default with the Insight Connector.  It is configured 

for use with the Insight Server.   
• By default, the Free/Busy information is updated by Outlook every 15 minutes.  Bynari 

recommends that you change this setting to a time value between 1 and 5.  This will 
ensure that your Free/Busy information is posted promptly. 

• If you are not using the Insight Server, you will need to change the default FTP address 
for posting your Free/Busy information. 

• This information is changed in Outlook by going to: 
o Tools > Options > Calendar Option 
o Click “Free/Busy Options…” 
o In the dialog window, you can add your server’s Free/Busy address. 
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Figure 17 – Outlook Free/Busy Calendar Options 
 

 
Figure 18 – Outlook Free/Busy Calendar Options 
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4.1.5 Hide Insight Connector Toolbar 
• Upon successful installation of the Insight Connector, the Toolbar will be displayed in 

Outlook by default.   
• The Toolbar can be hidden if desired. 
• To hide the Toolbar, go to View > Toolbars > Insight Connector 
• This will remove the the Insight Connector toolbar but will not stop it from working. 
• If you inadvertently hid the Toolbar,  you can “un-hide” it by following these steps: 

o View > Toolbars > Insight Connector 

 
Figure 19 – Outlook Toolbar Options 

 

4.1.6 Third Party Add-ins 
Hundreds of Third Party Add-ins are available for Microsoft Office, and many of those can be 
used with Outlook.  It is highly recommended that add-ins NOT be used in conjunction with the 
Insight Connector.  Add-ins can cause unpredictable behavior in Outlook. 
 

4.1.7 Multiple User Accounts 
The Insight Connector was designed to function as a MAPI extension to Outlook.  Because of the 
added functionality, the Insight Connector operates much like a hybrid between MAPI and IMAP.   
 
As with Exchange, only one MAPI account can exist per Outlook profile when using the Insight 
Connector.  Likewise, only one IMAP account may exist while using the Insight Connector. 
 
If a user manages multiple IMAP mailboxes, additional profiles need to be created within Outlook.  
If subsequent accounts are added into Outlook under the same profile as the Insight Connector, 
erratic behavior will occur. 
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4.2 Outlook 

4.2.1 Send/Receive 
• By default, Outlook is not setup to automatically Send/Receive email. 

 
Figure 20 – Outlook Tools, Options, Mail Setup, Send/Receive 
 

• To configure Outlook to automatically Send/Receive emails,  follow these steps: 
o Tools > Options > Mail Setup 
o Make sure that the “Send immediately when connected” is checked. 
o Select the Send/Receive button 
o Under the “Setting for group ‘All Accounts’”, is a setting titled, “Schedule an 

automatic send/receive every [5] minutes. 
o Check this setting to use automatic send/receive. 
o The numeric value (in minutes) represents how often Outlook will check for new 

emails.  Values can be anything from 1 to 1440 with 5 being the default. 
o Save these settings by selecting “Close” and “OK”. 
 

4.2.2 Offline Mode 
• The Insight Connector is fully compatible with the “Offline Mode” feature of Outlook.   

o To go in Offline or Online mode, click “File”, “Work Offline”. 

 
Figure 21 – Outlook Offline Mode 
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o To see if Outlook is in Offline Mode, look for the Offline Icon in the lower right corner of 

Outlook. 

 
Figure 22 – Outlook Offline Mode Icon 
 

• Considerations for going offline with the Connector: 
o If you use “download headers only”, make sure that you have clicked on the 

emails that you want to view before going “offline”. If not, you’ll see a blank email 
once you are offline. 

o If you use the Insight Server and “Auto-Registration” and know that you are going 
to be in an area without a network connection, switch Outlook into Offline Mode 
prior to disconnecting from your network.  If you do not go into Offline Mode 
while still connected to your network, a licensing dialog will open informing you 
that you do not have a valid license.  This will only affect users using Auto-
Registration because the Insight Connector attempts to validate a license with 
the key server upon startup.  Users that have manually entered a license key 
should not experience this behavior. 

 

4.2.3 Outlook Shutdown 
Closing Outlook is a simple task, but in the background, Outlook performs multiple processes 
Two basic ways to close Outlook are: 

1. Click the “X” in the upper right corner of the Outlook windows 
2. Click File > Exit  

There are times when the Outlook.exe process remains active even after the Outlook window 
disappears.  You may have noticed after closing Outlook that you are unable to restart it.  If you 
were to view the Task Manager, you would likely find multiple “outlook.exe” processes running 
concurrently.  All of these processes need to be “killed” before Outlook can be restarted.   
 
This can be caused by a number of different things.  Microsoft has been working on a fix for this 
issue since Outlook 2002 and has the issue almost completely fixed in Outlook 2007.   
 
Most of these issues are caused by Add-ins (or plug-ins) to Outlook.  Here are a few things you 
can check to help make Outlook shutdown normally. 

• Business Contact Manager (BCM) – this is known to leave the outlook.exe process 
open after Outlook has been closed.  A complete tutorial on how to disable BCM can be 
found on Microsoft’s Support Site: http://support.microsoft.com/kb/903094 
 

• Antivirus Software – Multiple versions of antivirus software are available with Outlook.  
The general rule of thumb is that if the antivirus software places a Toolbar within your 
Outlook, it may be preventing Outlook from closing properly.   
 
Empty Deleted Items folder upon exiting – This option (a feature of Outlook) 
automatically deletes your deleted items upon exiting Outlook.  It has been reported to 
Microsoft that this is a known cause for preventing Outlook from closing properly.  To 
verify your settings on this feature select: Tools > Options > Other.  The first line is the 
option to “Empty the Deleted Items folder upon exiting”.  Uncheck the box if it is checked. 
 

• ActiveSync – When the PDA is in the cradle, ActiveSync has been reported to prevent 
Outlook from closing properly. 
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It is recommended, if you are encountering this issue, that you look for Outlook Add-ins.  To 
check your Outlook Add-ins: 

• Tools > Options > Other 
• Select Advanced Options > Add-In Manager 

 

 
Figure 23 – Outlook Tools, Options, Other, Advanced Options 
 
This option shows everything that is running in Outlook as an Add-in.  If you are encountering an 
issue with shutting down Outlook completely and you suspect it is an Add-in, follow the below: 

1. Disable all Add-ins except for Bynari Insight Connector 3.x 
2. Close all of the dialog window by selecting “OK” until complete 
3. Close Outlook 
4. Ctrl + Alt + Del > Task Manager 
5. Review the processes to insure that “outlook.exe” is not running, if it is, select it and then 

select “End Process” 
6. Restart Outlook and allow for all email processes to complete before moving to the next 

step. 
7. Close Outlook 
8. Check the Task Manager to see if the “outlook.exe” process closed properly.  If it did 

close properly go to step 10.   
9. If “outlook.exe” did not close properly, contact Bynari Support by opening a support ticket: 

http://www.bynari.net/support or by telephone at (214)350-5772 X26 with your findings. 
10. Go back into the Outlook Add-in Manager and enable one more Add-in and repeat steps 

2-8. 
11. Repeat these steps until you discover which Add-in is preventing Outlook from closing 

properly. 
 


